Critical Vulnerability Detected in WooCommerce
There was a security issue discovered in WooCommerce recently, they’ve already patched it so updating to the most recent version (v5.5.1) should resolve the issue.
If you run into a problem updating to the most recent version, update within your release branch first and then update to the latest version.
For example, that means if you find a Woo site running 4.7.1 you would need to update it to the latest 4.7.x version available and then update to the latest (5.5.1 as of this writing).
If you do run into issues with updating versions older than 5.5.x please let the Builder 3’s know.
Internal Builders: For information on updating Woo via SSH, please follow this guide.
Vendors: Please submit a technical clarification if you run into any issues updating WooCommerce.
WooCommerce Source Article: https://woocommerce.com/posts/critical-vulnerability-detected-july-2021/